
Scorecard Composer Features 



SCORECARD COMPOSER FEATURE LIST 
●​ Pairing Groups  

○​ Print scorecards for some or all pairing groups 
○​ Print extra scorecards with no player names 
○​ Select Tournament used to display Playing Handicaps 

●​ Format 
○​ Default and custom page / paper sizes 
○​ 18- or 9-Hole scorecards 
○​ Print 1, 2, or 3 scorecards per page 
○​ Print individual or all players and pairs, entire foursomes, or teams 

■​ A player on multiple teams will be printed on multiple scorecards 
●​ Handicaps 

○​ Tournament specific Playing Handicaps 
○​ User defined handicaps can be displayed, along with the coinciding dots for each 

hole 
●​ Additional Info & Tees 

○​ Extra rows can be added to the scorecard for team scoring, match status, or any 
other reason 

■​ Rows can contains all cells, just Out, In and Total Cells, or just Out and In 
cells 

■​ Cells in added rows can be merged together to create larger cells 
○​ Marker Notes for individuals or pairs can be added 

■​ Player information (name and PH) can be shown for markers 
○​ If blind partners are used, they can optionally be displayed on the scorecard 
○​ Slashes can be added to all scoring cells 
○​ Option to show player initials for back 9 half of card 
○​ Custom Tee Abbreviations can be displayed for each player. 
○​ Multi-Tee Starting holes can be highlighted 
○​ Pace of play expected hole finish times can be displayed on any scorecard in the 

main scoring area and the Marker Notes 
○​ Tee rows can either be just for the players on the scorecard, or some or all tees 

can be displayed 
●​ Fonts & Colors 

○​ Customize font style, font size, font color, bold, italic and underline for all text 
displayed 

○​ Customize row height and margin between rows 
○​ Customize background color for all cells on scorecard, including the color opacity 
○​ Apply all customization to all or some text or cells 
○​ One click apply or clear default tee colors 

■​ Custom tee colors are shown. Combo tee colors can be displayed as well. 
●​ Header & Footer 

○​ Unlimited text fields can be added to the scorecard and placed in any position 



○​ Unlimited Event / League, Round, Course, Tournament, Division, Flight, Team, 
Player specific datafields can be added to all scorecards and placed in any 
position 

○​ Specific font and background colors can be applied to text, fields and scorecard 
cells 

○​ Unlimited logos, banners, background or uploaded images can be added and 
placed in any position 

■​ Dynamic Primary and Secondary logos can be added to the card to 
display specific images for each event or round, preventing the need to 
change images each time 

■​ Other saved images can easily be added to scorecards 
■​ Any image can be uploaded to display on a scorecard 
■​ Adjust transparency for saved or uploaded images  

○​ Add unlimited rectangles, squares and lines 
■​ Customize the line style. width, color and angle 
■​ Customize the rectangle or square style. width, color, angle and fill color 

○​ Arrange items added to scorecard for placement, including in front or back of 
other items 

○​ Display vertical fold line, background grid and/or perforation lines during creation 
to aid item placement on scorecards. (These are not displayed on the printed 
scorecards) 

●​ Scorecard Sharing / Community Reports 
○​ Share created scorecards with the rest of the Golf Genius Tournament 

Management Community of users 
○​ Import and uniquely edit any of thousands of previously shared reports and 

scorecards 
 
 
 
GPT Summary based on Scorecard Composer KB Articles 

1. Purpose of the Scorecard Composer 
Scorecard Composer is Golf Genius’s tool for designing and customizing printed golf scorecards 
for any round or event. It works like the other “Composer” tools (Report Composer, Page 
Composer), but is specifically optimized for: 

●​ Laying out holes, pars, handicaps, tees, and scoring rows. 
●​ Applying handicap stroking rules correctly. 
●​ Customizing fonts, colors, and branding. 
●​ Controlling which pairing groups appear and how they’re presented. 
●​ Sharing and discovering scorecard templates via the community. 

You access it from Rounds > Print Scorecards > New Scorecard for design, from Rounds > Print 
Scorecards to use/print existing designs, or from Rounds > Report Center > New Document or 



saved Scorecard.
 

2. Creating and Organizing Scorecards 

Creating a New Scorecard 
1.​ Go to Rounds > Print Scorecards > New Scorecard. 
2.​ Name the scorecard: 

●​ If the name matches something in Community Reports/Scorecards, the system 
surfaces matching templates (based on name/category/tags) so you can reuse or 
copy instead of starting from scratch. 

3.​ Choose a Report Center folder to store the scorecard configuration. 
4.​ Click Save to open the Scorecard Composer. 

Overall Interface 
The composer is divided into tabs, each controlling a key aspect: 

1.​ Pairing Groups 
2.​ Format 
3.​ Handicap Stroking 
4.​ Additional Info & Tees 
5.​ Fonts & Colors 
6.​ Header & Footer 

On the canvas you see the scorecard layout (including the scorecard table). You can: 
●​ Move and resize any object (scorecard table, logos, shapes, text blocks). 
●​ Use the preview pane below to see a live rendering. 
●​ Click Refresh Preview after changes to validate the final print look. 
●​ Click Save at any point to preserve your setup. 

 

3. Pairing Groups Tab 
This tab answers: “Whose scorecards are we printing, and which tournament drives them?” 
Key capabilities: 

●​ Select Tournament for Stroking 
●​ You choose which tournament (within the round) controls: 

■​ Which players/teams appear. 
■​ How handicaps and stroking are applied (in conjunction with the Handicap 

Stroking tab). 
●​ View and Select Pairing Groups 

●​ Shows all pairing groups for the chosen tournament/round. 
●​ Lets you choose which groups will have scorecards printed: 

■​ All groups. 



■​ Specific groups you select (e.g., only shotgun group A1–A5, or specific 
tee times). 

●​ You can also choose to print extra scorecards with no player names, but with all 
the other customization options displayed 

●​ Ensures that what you design is actually tied to real pairings and that the correct groups 
get the customized scorecards. 

 

4. Format Tab 
The Format tab sets the fundamental physical layout and structure of the scorecard before 
detailed styling. 
Typical settings include: 

●​ Paper and Card Orientation 
●​ Standard paper size (e.g., letter/A4) and orientation (portrait/landscape). 
●​ Overall card layout (e.g., front 9/back 9 on one side, or across fold). 
●​ Or, create any page size you would like for your preferred scorecards 

●​ Scorecard Table Layout 
●​ Number and arrangement of: 

■​ Holes (front 9/back 9, 18‑hole view). 
■​ Number of scorecards per page, 1, 2 or 3 
■​ Print for all or 1 player, 1 or two pairs, or entire team 

●​ Margins and Placement 
●​ Overall margins on the page. 
●​ Alignment of the scorecard table on the canvas (centered, left/right shifted). 

The Format tab provides the baseline grid on which all other customizations (stroking, extra info, 
fonts/colors, header/footer) are layered. 

 

5. Handicap Stroking Tab 
This tab controls how handicaps are applied and displayed on the scorecard, ensuring the 
printed card matches competition rules. 
Key capabilities typically include: 

●​ Handicap Stroking and Playing Handicap are based on the Tournament chosen in the 
Pairing Groups tab 

●​ An alternative is to create a User Defined Stroking Method 
●​ Choose the method by which strokes are allocated across holes—for example: 
●​ Full course handicap vs. playing handicap. 
●​ Net/gross formats. 
●​ Stroke distribution based on hole handicaps. 
●​ Number of Strokes and Rounding 

■​ Whether players receive full, partial, or adjusted strokes. 
■​ Handling of fractional strokes (rounding rules). 



●​ Display of Strokes 
●​ Options to show or hide stroke indicators on the scorecard: 
●​ Marking which holes receive strokes. 
●​ Displaying a “stroke index” line or using other indicators. 

 

6. Additional Info & Tees Tab 
Once basic structure and stroking are set, Additional Info & Tees controls what extra information 
appears on the card and which tees are printed. 
Key features: 

Tee Selection and Display 
●​ Choose which tees appear on the card: 

●​ Men’s vs. Women’s tees. 
●​ Multiple tee options (e.g., Blue, White, Red). 

●​ Define and display for each tee: 
●​ Yardages by hole. 
●​ Par by hole (if tee‑specific). 
●​ Course rating/slope if included on the card. 

Extra Scoring and Information Rows 
●​ Add extra scoring rows, such as: 

●​ Additional player lines (for more players per group). 
●​ Team or marker rows. 
●​ “Out / In / Total / Net” rows depending on your format. 

●​ Add other useful information, like: 
●​ Pace of play information (time par by hole, total expected time). 
●​ Add a column and display player initials 
●​ Show Tee Abbreviations next to player names 
●​ Add slashes to score boxes for gross/net scores 
●​ Print blind partner’s name or not 
●​ Display just tees used for that pairing group or print all selected tees on every 

card 
This tab is where you tailor the card to display pertinent information for the player, pair or team 
to guide them through their round. 

 

7. Fonts & Colors Tab 
The Fonts & Colors tab controls the look and feel of text and cell backgrounds across the 
scorecard. 
Main capabilities: 



●​ Font Family, Size, and Style 
●​ Adjust global or section‑specific: 
●​ Font type (within available fonts). 
●​ Font size. 
●​ Bold/italic/underline options. 
●​ Apply different font settings to: 
●​ Hole numbers row. 
●​ Par/handicap/yardage rows. 
●​ Player scoring lines. 
●​ Headers or totals rows. 

●​ Text Color 
●​ Set text color for: 
●​ Specific cells (e.g., par or handicap line). 
●​ Entire rows or sections (e.g., highlight total row or “Net” row). 

●​ Background Colors 
●​ Apply background (fill) colors to: 
●​ Specific cells (e.g., highlight par row or certain tee lines). 
●​ Whole rows or blocks (e.g., separate front 9/back 9 visually). 

This tab is crucial for: 
●​ Branding (club colors, sponsor colors). 
●​ Readability (clear distinction of holes, tees, and scoring rows). 
●​ Highlighting important info (e.g., net rows, pace of play rows). 

 

8. Header & Footer Tab 
The Header & Footer tab lets you design everything around the scorecard table at the top and 
bottom of the page. 
You can: 

Add and Edit Objects 
●​ Text Fields 

●​ Insert custom text blocks: 
●​ Event name, date, round, starting time, starting hole, Flight or Division name, 

Handicap Analysis 
●​ Club name and contact info. 
●​ Local rules, special notes. 
●​ Player and marker signature lines or boxes 

●​ Images/Logos 
●​ Add club logos, sponsor logos, or other images. 
●​ Resize and position them anywhere on the canvas. 

●​ Other Objects 
●​ Shapes or lines (depending on available tools) to: 



●​ Separate header/footer from the main card. 
●​ Create banners or boxes around key information. 

Placement and Sizing 
●​ Move any object freely on the canvas: 

●​ Position logos top‑center, left, or right. 
●​ Place event names prominently at the top. 

●​ Resize objects: 
●​ Enlarge logos for visibility on printed cards. 
●​ Adjust text boxes so longer titles fit nicely. 

Combined with the Fonts & Colors tab, Header & Footer makes it possible to produce 
professional, club‑branded scorecards with sponsor recognition and clear event identification. 

 

9. Canvas Interaction and Preview 
Across all tabs: 

●​ Drag & Resize 
●​ The scorecard table itself can be moved and resized. 
●​ All other elements (text blocks, images, shapes) can also be dragged and 

resized. 
●​ Layering 

●​ Although not always called out explicitly, composer tools generally allow sending 
objects front/back to manage overlaps (e.g., text on top of a background shape). 

●​ Live Preview 
●​ Below the canvas is a preview pane: 

■​ Shows how the final set of scorecards will look. 
■​ Updates when you click Refresh Preview after edits. 

●​ This is essential to: 
■​ Confirm alignment. 
■​ Verify correct pairing group info (names, tees). 
■​ Check stroking, tees, and layout before printing. 

●​ Saving 
●​ Use Save to store the configuration. Saved scorecards appear in: 

■​ The folder you chose. 
■​ Scorecard lists under Print Scorecards and in the related Report Center 

area. 
 

10. Printing Scorecards 
(From “Printing Scorecards”) 
Printing is done from the Rounds > Print Scorecards area: 



●​ You select: 
●​ The scorecard definition (the template you designed). 
●​ The round/tournament context. 
●​ The pairing groups to print (sourced from the Pairing Groups tab settings). 

Printing options typically include: 
●​ Paper size and orientation (inherited from Format tab). 
●​ Number of scorecards per page or per sheet, depending on printer/format options. 
●​ Ability to: 

●​ Print directly. 
●​ Generate PDFs (where supported by the platform) for emailing or offline printing. 

The Scorecard Composer ensures printed cards are correctly formatted, stroked, and 
personalized for each group or player. 

 

11. Sharing Scorecards with the Community 
After you design a scorecard, you can share it as a template with the broader Golf Genius user 
community: 
Steps: 

1.​ Click Share Scorecard. 
2.​ Choose appropriate categories (e.g., type of event, format) to help others find it. 
3.​ Toggle Published to YES. 
4.​ Click Save. 

The template goes into a review process: 
●​ Golf Genius staff verify: 

●​ It’s suitable for sharing. 
●​ It doesn’t unnecessarily duplicate existing public templates. 

Once approved, it becomes available to other clubs and admins to copy and adapt. 
 

12. Discovering and Managing Scorecards 
(From “Managing and Discovering Scorecards”) 

Discovering Community Scorecards 
Instead of starting from scratch, you can: 

●​ Browse community scorecard templates created and shared by other users. 
●​ Filter by categories, event types, or other metadata. 
●​ Copy a community template into your own environment and then: 

●​ Adjust Pairing Groups, Format, colors, header/footer. 
●​ Customize for your club’s branding or specific competition rules. 

This drastically reduces setup time for common formats (e.g., standard 18‑hole stroke play, club 
championship, team events). 



Managing Your Scorecards 
You can: 

●​ Organize scorecards in appropriate folders. 
●​ Edit existing scorecards: 

●​ Update stroking rules for new seasons. 
●​ Change tees or formats. 
●​ Refresh branding or sponsor logos. 

●​ Control sharing/publishing: 
●​ Update categories. 
●​ Unpublish a scorecard if you no longer want it shared with the community. 

Scorecards are treated as reusable assets—you design once, then manage, copy, and refine as 
needs change. 

 

13. How All the Scorecard Composer Pieces Fit Together 
End‑to‑end, Scorecard Composer allows you to: 

1.​ Tie scorecards to real groups and tournaments 
●​ Via the Pairing Groups tab and dynamic stroking rules. 

2.​ Define the physical and logical layout 
●​ Using the Format tab (holes, rows, page setup). 

3.​ Apply accurate handicap stroking 
●​ With the Handicap Stroking tab, aligned with competition rules. 

4.​ Include all relevant playing information 
●​ Through Additional Info & Tees (tees, yardages, pace of play, extra scoring rows). 

5.​ Brand and style the scorecard 
●​ With Fonts & Colors and Header & Footer tabs (logos, text, colors). 

6.​ Visually refine and confirm the layout 
●​ Dragging/resizing objects on the canvas and using Refresh Preview. 

7.​ Print and reuse efficiently 
●​ Printing from Print Scorecards, reconfiguring for new rounds, and managing 

templates. 
8.​ Leverage the Golf Genius community  

●​ Discover existing templates and share yours to help other users. 
 



Scorecard Examples 



 

SCORECARD - SCRAMBLE - FOURSOME NAMES 
 

 
 
 
SCORECARD - 6/6/6 
 

 
 
SCORECARD - Ringer 
 



 
 
 
 
 
SCORECARD - Basic 4 Players 
 

 
 
 
SCORECARD - SINGLES MATCH PLAY 
 



 
 
SCORECARD - INDIVIDUAL CHAMPIONSHIP

 
 
SCORECARD - 9 HOLE MATCH PLAY

 
 
 



Report, Page & Spreadsheet Composer 
Features 



Report Composer Features 
●​ Create reports from scratch or import one of thousands of reports shared by our entire 

user community and make edits, if needed 
●​ Use a default page size and layout or create your own custom layout 
●​ Content 

○​ Report Header content will just appear on the first page of your report 
○​ Page Header content will appear at the top of all pages of your report 
○​ Column Header content will appear at the top of each column 

■​ Separate columns can have unique headers 
○​ Content included can have multiple levels of information available 

■​ Print content for: 
●​ Courses 
●​ Divisions 
●​ Flights 
●​ Teams 
●​ Foursomes 
●​ Players 
●​ Match Play pairs & singles 
●​ Stroke Play pairs 
●​ Rounds 
●​ Tees 

○​ Page Footer content will appear at the bottom of all pages of your report 
○​ Report Footer content will just appear on the bottom of the last page of your 

report 
●​ Content customization 

○​ Fonts & Colors 
■​ Customize font style, font size, font color, bold, italic and underline for all 

text displayed 
■​ Apply all customization to all or some text 

○​ Page Control 
■​ Stick to Column - maintain information pertaining to a field in the same 

column on each page 
■​ Page or column Breaks - begin content on a new page or column for a 

defined field 
○​ Sort 

■​ Sort the content based on any field chosen, whether it’s visible in the 
report or not 

○​ Filter 
■​ Filter the content of the report to show only for values of a certain field 

○​ Design elements 
■​ Unlimited text and fields can be added to the content 
■​ Unlimited saved or uploaded images can be added to the report 



■​ Add rectangles 
●​ Variable size, border width, border radius, border color and 

background color 
■​ Add lines 

●​ Variable length, angle, width and color 
■​ Arrangement 

●​ Place content anywhere in the report 
●​ Alignment tools, like snap to position and alignment indicator lines 
●​ Arrange content in front or behind other content. Useful for 

watermark images 
■​ One click duplicate and delete of content 
■​ Move selected items as a group to maintain alignment and spacing 

○​ Instant report previews before printing 
○​ Report Sharing / Community Reports 

 
AI Summary of capabilities of Report Composer 

1. Overall Purpose and Positioning 

●​ Report Composer lets you build fully customized, data‑driven reports when 
standard system reports don’t give the exact layout or content you need. 

●​ It works similarly to Page Composer, but is focused on repeating, data‑oriented 
reports (player/teams/flights lists, scoreboards, gift cert reports, etc.), rather than 
one‑off pages or posters. 

●​ Reports you build can be reused, configured for different rounds/tournaments, 
and even published to the Community Reports library. 

Typical uses: 

●​ Condensed or stylized alpha lists 
●​ Custom flight / division / team reports 
●​ Custom scoreboards 
●​ Gift certificate or prize reports 
●​ Branded printable reports for events or leagues 

 

2. Initial Setup & Layouts 

Creating a New Report 



From Rounds > Report Center > New Document > New Report, you specify: 

1.​ Name 
●​ Used to identify the report and to match potential Community Reports with 

the same name/category/tags for easy reuse. 
2.​ Layout 

●​ Defines the paper size, number of columns (single or multi‑column), 
header/footer heights, margins, and overall printable area. 

●​ You can reuse existing layouts or create custom ones (see below). 
3.​ Report Center Categories 

●​ Controls where the report appears in the Report Center so it’s easier to 
find/run later. 

Creating and Managing Layouts 

●​ Via Manage Layouts > Add New Layout, you can: 
●​ Set custom page dimensions (e.g., large format boards). 
●​ Adjust number of columns (e.g., 2‑column scoreboard). 
●​ Define Report/Page Header and Footer heights. 
●​ Set margins and other layout properties to match your paper/board or 

printing needs. 
●​ Once created, layouts can be reused by multiple custom reports. 

 

3. Report Structure & Hierarchy 

Every Report Composer report has a structured hierarchy that determines what appears 
where: 

1.​ Report Header 
●​ Appears only on the first page. 
●​ Typically includes report title, club name, logos, and any headline 

information. 
2.​ Page Header 

●​ Appears on every page. 



●​ Often repeats the report name or key information (event name, round, 
date, etc.). 

3.​ Column Header 
●​ Optional, but key for reports that are grouped or sorted by division, flights, 

or teams. 
●​ Supports multiple column headers in multi‑column layouts (e.g., each 

column can have its own header). 
4.​ New Content Area (Body) 

●​ The core, repeating data area of the report. 
●​ Can be drilled into multiple content levels (e.g., Division → Flight → Team 

→ Player). 
●​ Each level can have its own design, sorting, filtering, and pagination 

controls. 
5.​ Page Footer 

●​ Appears on every page. 
●​ Common uses: page numbers, print date/time, event name, disclaimers. 

6.​ Report Footer 
●​ Appears only on the last page. 
●​ Ideal for notes, final totals, or end‑of‑report messages. 

This structure lets you build complex, multi‑level reports where headers/footers and 
content areas are precisely controlled for printing and readability. 

 

4. Content Levels & “New Content Area” Controls 

Within the New Content Area (body) you define how data is grouped and repeated: 

Choosing Content Levels 

●​ You select content levels (e.g., Division, Flight, Team, Player) via a dropdown. 
●​ Each selection must fit logically into the hierarchy; the system only allows valid 

combinations. 
●​ Examples: 

●​ Division → Player (per‑division player report) 
●​ Division → Team → Player (teams grouped within divisions, then players 

within teams) 



●​ Flight → Team 
●​ Player (simple alpha list by player) 

Editing / Re‑ordering Levels 

●​ Use the gear icon on a content level to: 
●​ Adjust which entity that level represents (e.g., change from Flight to 

Team). 
●​ Insert another content level above or below (e.g., add Team above 

Player). 
●​ Removing a level: 

●​ Click the red Remove button on that level when allowed. 
●​ If removing would break the hierarchy (e.g., leave a lower level with no 

valid parent), the remove option is disabled. 

This model lets you precisely control the “looping” structure of the report: which groups 
print, and in what nested order. 

 

5. Structure Level Controls: Page/Column Breaks, 
Filtering, Sorting, Design 

Each structural/content level (e.g., Division, Flight, Team, Player) has its own control bar 
with: 

1.​ Page Break (Single Column Report) 
●​ Forces page breaks between groups in single‑column layouts. 
●​ Example: each flight prints on a new page; each team’s info starts on a 

fresh page. 
2.​ Page Control (Multi‑Column Report) 

●​ Controls page and column breaks in multi‑column layouts. 
●​ Lets you choose whether a new group starts in a new column or on a new 

page. 
3.​ Filter 



●​ Limits which instances of that level are included (see detailed filtering 
below). 

●​ Example: print only specific flights, only certain teams, or only players 
meeting a criterion. 

4.​ Sort 
●​ Controls order of items at that level (see sorting below). 
●​ Example: alpha list by last name, teams by total index, certificates by 

finishing position. 
5.​ Design 

●​ Opens a design surface dedicated to that level, where you control exactly 
what prints and how it looks for that row/section. 

Special Grouping Option for Player-Level Reports 

●​ When the first structure level is set to Player, there is a Group By option: 
●​ No Grouping – players listed straight through. 
●​ Last Name Initial – the system inserts alphabetical breaks by last initial 

(typical for alpha lists). 

 

6. Designing Content at Each Structure Level 

Clicking Design for any level opens a dedicated canvas for that level. 

Design Canvas & Space Control 

●​ A grey area at the top/bottom can be dragged to increase/decrease vertical 
space allocated to that level. 

●​ Each level’s design is independent; switching levels via their Design button takes 
you to that level’s layout. 

Placeholders & Preview 



●​ Numbers in the design represent field placeholders. 
●​ Hovering over them shows which field they represent (e.g., Player Name, 

Handicap Index). 
●​ You can refresh the preview to see how changes will look with live data before 

finalizing. 

Text Editor & Dynamic Fields 

When you click text or a placeholder, you open the text editor, which has two main 
sections: 

1.​ Text Editor (left) 
●​ Type static text and format it: 

●​ Font size, color, style (bold/italic/underline). 
●​ Alignment, indentation. 

●​ Combine static text with dynamic fields: 
●​ Example: Index: [Handicap Index field] will print “Index: 12.3” 

(etc.) for each player. 
2.​ Data Fields Panel (right) 

●​ Insert dynamic fields related to: 
●​ Player 
●​ Roster Custom Fields 
●​ Round Custom Fields 
●​ Pairings 
●​ Division / Flights / Teams 
●​ Handicap 
●​ Tournament / Round / Course 
●​ And other tournament‑related entities. 

●​ These fields change automatically based on which round/tournament the 
report is configured for. 

After editing, you Apply Text Change to save those changes for that level. 

 

7. Visual & Layout Tools: Lines, Rectangles, Images, 
Logos, QR Codes 



Within the design area, the toolbox gives you visual layout components (availability may 
vary by structure level): 

●​ Primary Header 
●​ Inserts your custom report header object. 

●​ Golf Hub QR Code 
●​ Places a scannable QR code that links to the event/league’s Golf Hub 

page—handy for scoreboards or printed notices. 
●​ Primary Logo / Secondary Logo 

●​ Inserts club logos, which you can move, resize, and layer. 
●​ Photo from Album / Upload Photo 

●​ Use existing photo albums or upload new images for branding, sponsor 
logos, or background images. 

●​ Add Rectangle 
●​ Draw rectangular shapes; customize: 
●​ Size via drag handles. 
●​ Fill color. 
●​ Border color and width. 
●​ Useful for background shading, boxes around groups, or callout areas. 

●​ Add Line 
●​ Add lines of any length, width, color, and angle. 
●​ Use for: 
●​ Column separators. 
●​ Underlines or section dividers. 
●​ Diagonal or decorative lines if desired. 

●​ Send to Back / Send to Front 
●​ Control layering of overlapping objects (text, images, shapes). 
●​ Example: send a watermark image to the back behind text. 

●​ Duplicate 
●​ Make a copy of any object (text, line, rectangle, logo) and reposition it. 

●​ Delete Item 
●​ Remove a selected object from the layout (irreversible once you save). 

●​ Group / Ungroup 
●​ Select multiple objects (Shift/Cmd + Click) and Group them: 
●​ Makes them move and layer as a single unit. 
●​ Grouping persists after saving. 
●​ Ungroup to manage them individually again. 



These tools work across Report Composer and Page/Report Page Composer, enabling 
fine‑grained visual design of scoreboards, reports, and branded documents. 

 

8. Filtering with Report Composer 

(From Filtering with Report Composer) 

Filtering lets you restrict which items print at each structure level: 

●​ Apply filters to: 
●​ Flights 
●​ Teams 
●​ Players 
●​ Or other structure levels that support filters. 

●​ You might filter by: 
●​ Specific divisions or flights (e.g., only Championship Flight). 
●​ Player or team attributes (index ranges, custom fields, gender, etc.). 
●​ Participation, scoring or roster criteria (depending on available fields). 

Key points: 

●​ Filters are set per structure level, so you can: 
●​ Show only certain divisions but all players within them, or 
●​ Show all divisions but only specific players (e.g., those in a particular 

category). 
●​ Filtering is essential when you want one generic report design but different target 

subsets for printing or exporting. 

 

9. Sorting with Report Composer 

(From Sorting with the Report Composer) 

Sorting controls the order in which elements appear at each level: 



●​ Typical examples: 
●​ Players: 
●​ Alphabetical by last name (for alpha lists). 
●​ By gross or net score. 
●​ By index or handicap. 
●​ Teams: 
●​ By total team index. 
●​ By starting hole or tee time. 
●​ Flights / Divisions: 
●​ By name, order configured in the tournament, or by a custom ranking field. 
●​ Gift Certificates / Prizes: 
●​ By finishing position in the event. 

Per‑level controls: 

●​ Each level has its own Sort configuration. 
●​ You can use primary, secondary, etc. sort criteria (depending on the article’s 

implemented behavior) to break ties or fine‑tune order. 

Sorting plus filtering allows highly tailored outputs—for example, a “Top 10 Net” list 
sorted by net score, while another view shows all players sorted alphabetically. 

 

10. Multiple Column Headers (Multi‑Column Reports) 

(From Multiple Column Headers with the Report Composer) 

In multi‑column layouts, column headers can be customized per column: 

●​ You can define distinct column headers for each column (e.g., Column 1 “Men’s 
Flights”, Column 2 “Women’s Flights”). 

●​ This is especially useful for: 
●​ Multi‑column scoreboards or alpha lists where each column might 

represent different divisions or flights. 
●​ Large boards where content is split across columns for readability. 



The multiple column header capability ensures that, even when data flows across 
columns, labels remain clear and appropriate for each section. 

 

11. Tips, Shortcuts & General Composer Workflow 

(From Report Page Composer Tips and Shortcuts) 

Across Report Composer and Page Composer, the system supports various efficiency 
and layout tips, such as: 

●​ Dragging to resize design regions (headers, footers, content areas). 
●​ Using duplicate and grouping to replicate sections quickly (e.g., consistent logo 

blocks, column header lines). 
●​ Refreshing the preview frequently while designing to verify: 

●​ Data binding (dynamic fields show correct values). 
●​ Pagination and column breaks. 
●​ Visual alignment and spacing. 

These are workflow accelerators that reduce trial‑and‑error and help maintain 
consistency across multiple reports or scoreboard designs. 

 

12. Printing Scoreboards 

(From Printing Scoreboards) 

While not limited to Report Composer, there’s significant overlap: 

●​ Scoreboards often use Report/Page Composer to create large, printable layouts: 
●​ Single or multi‑column scoreboards. 
●​ Boards that show team or player scores, along with logos and event 

branding. 
●​ You can: 

●​ Use custom layouts sized to your physical boards. 
●​ Apply sorting and filtering to show only certain divisions or leaderboards. 
●​ Include QR codes to drive viewers to live scoring on Golf Hub. 



●​ Printed outputs can be used: 
●​ On easels or posting boards. 
●​ As handouts for players, staff, or sponsors. 

Report Composer gives the structured, data‑driven foundation; Page/Report Page 
Composer adds the flexibility to design high‑impact physical scoreboards around that 
data. 

 

13. Templates and Community Sharing 

Report Templates 

●​ A report can be toggled as a Template: 
●​ Restricts who can edit the report (typically to admins or designated roles). 
●​ Useful for standardized club‑level documents you don’t want accidentally 

modified. 

Community Reports 

●​ You can publish your report to the broader Golf Genius community: 
●​ Other users can discover and copy it for their own events. 

●​ You can also browse community reports: 
●​ When you name a report, the system checks for matching community 

documents by name, category, and tags and offers links to those 
templates. 

This ecosystem of templates and shared content reduces the need to build complex 
reports from scratch. 

 



14. Configuring Reports for Specific Rounds & 
Tournaments 

Once a report is designed, you must configure its dynamic fields for each usage: 

●​ From Rounds > Report Center, locate the report and click Configure. 
●​ You’ll see: 

●​ A list of dynamic fields used in the design. 
●​ Each field’s purpose (e.g., “Round 1 Tee Time”, “Round Score”, 

“Tournament Name”). 
●​ A live preview showing what part of the report changes when you adjust 

that field. 

Examples: 

●​ Tee Time Fields: 
●​ Tee times vary by round, so you select which round’s tee time field to bind. 

●​ Score Fields: 
●​ To display “Round 1 Score next to each player’s name,” you select the 

appropriate round and tournament combination for that score field. 
●​ Reusing Reports Across Rounds: 

●​ Build once (e.g., in Round 1). 
●​ Configure for Round 1. 
●​ Then configure again for Round 2 by mapping dynamic fields to Round 2 

objects. 

This configuration mechanism is what makes reports reusable and adaptable across 
events and rounds without redesigning the layout. 

 

15. Platform Notes & Product Versions (Context from 
Training Material) 

From the training material you included: 



●​ Visual color schemes may differ between Golf Genius product platforms (e.g., TM 
Club vs. TM Club Premium), but: 

●​ The feature set of Report Composer and related tools is consistent. 
●​ Screenshots/videos you see may not match your exact color theme, but 

functionality is the same. 
●​ TM Club vs. TM Club Premium: 

●​ TM Club Premium offers additional features beyond TM Club. 
●​ If a Report/Composer feature is Premium‑only, it is labeled with the TM 

Club Premium logo in documentation. 
●​ Report Composer itself is part of a broader set of TM Tournament 

Management capabilities; availability depends on your subscription. 

 

16. How This All Fits Together in Practice 

Putting it all together, the Report Composer + Page/Report Page Composer toolset 
gives you: 

●​ Data structure control 
●​ Choose how content is grouped (Division/Flight/Team/Player) and ordered 

(sorting, grouping). 
●​ Data selection control 

●​ Filter which objects appear. 
●​ Pagination/control 

●​ Force page or column breaks by structure level for clean layouts. 
●​ Visual and branding control 

●​ Add logos, photos, QR codes, lines, rectangles, headers/footers, and 
structured text. 

●​ Reusability and sharing 
●​ Configure for different rounds/tournaments, protect templates from edits, 

and share or borrow from the community. 

 
 
 
 
COURSE STATISTICS 



 
 

 



Report Examples 



Alpha List with Groupings 



 
 
CART SIGN 



 

 
 
Tee Sheet 



 
 
Combined Alpha / Tee Sheet 



 
 
Round Robin Tee Sheet 



 
 
Multi Round Match Play Cart Sign 
 



 
 
 
 
Bag Labels 



 
 
Team Scoreboard 



 



 



Round Robin Scoreboard



 



 
Ryder Cup 



 



 
College Tournament 



 



 
Course Statistics 

 
 



Pace of Play Report

 
 
Gift Certificates 



 
 
Locker Signs 



 



Page Composer Features 



Page Composer Features 
●​ What Page Composer is:​

A highly customizable tool for creating printable materials (reports, labels, cart signs, 
etc.) within Golf Genius Tournament Management, similar in spirit to Report Composer 
but focused on page‐based layouts. 

●​ Core capability:​
Design, configure, and print documents that pull in dynamic tournament data (players, 
scores, rounds, etc.), with full control over layout, text, images, and page structure. 

Creating and Managing Page Reports 

Create a New Page 
From Rounds > Report Center > New Document > New Page, you can: 

1.​ Name the report 
●​ The system checks Community Reports for existing documents with the 

same/similar name, category, and tags. 
●​ If matches exist, you see how many and get a link to quickly review them and 

potentially reuse rather than starting from scratch. 
2.​ Select a Form 

●​ A Form defines paper size and layout grid (e.g., Avery 5160 labels, custom 
cart-sign forms). 

●​ If a needed form doesn’t exist, you can go to Manage Forms > Add New Form 
(detailed later in the article). 

3.​ Choose “Print for every” 
●​ Defines the unit of repetition for the report (its scope): 

●​ Examples: 
●​ “Every player” for things like bag tags/labels. 
●​ “Every pair” for cart signs. 

●​ This determines how dynamic data is repeated across the pages. 
4.​ Assign Report Center categories 

●​ Decide where this report will appear in the Report Center for organization and 
retrieval. 

After completing the setup, you Save to create the new Page Composer document. 

Edit an Existing Page 
From Rounds > Report Center: 

1.​ Search for the page report. 
2.​ Hover over it and click Edit to open it in Page Composer and change layout, content, or 

settings. 



Page Composer Layout & Settings 

Main Layout 
The interface is divided into: 

●​ Left side: Tool palette and settings (text, fields, images, shapes, QR code, layering 
controls, etc.). 

●​ Right side: Design canvas showing the page/form where you position and edit content. 

Page-Level Settings 
In the Settings area you can adjust: 

1.​ Name – Rename the report. 
2.​ Print for every – Change the scope (per player, per pair, etc.). 
3.​ Status & Community Sharing 

●​ You can publish or unpublish the report to the Golf Genius Community Reports. 
●​ This controls whether other users can find and use your design. 

4.​ Form 
●​ Change the paper size and layout by picking a different form (e.g., Avery 5160, 

custom cart-sign form). 
●​ If you need a new form, you can go to Edit > Add New Form. 

5.​ Template Flag (Customer Managers Only) 
●​ Customer managers with the proper permissions can mark a report as a 

template. 
●​ This restricts who can modify it and effectively protects “standard” organization 

designs from casual edits. 

Content & Design Capabilities 

Adding Text and Dynamic Fields 
Using Add Text/Field: 

●​ You can insert: 
●​ Static text (headings, labels, instructions). 
●​ Dynamic fields (placeholders that fill from tournament data at print time), such as: 

■​ Player-related fields 
■​ Roster custom fields 
■​ Round custom fields 
■​ Pairings 
■​ Divisions/flights/teams 
■​ Handicap data 
■​ Tournament details 



■​ And more 
●​ When you click a dynamic field in the list, it is inserted at your cursor position as a 

placeholder. 
●​ At print time, these placeholders are automatically replaced with the appropriate data, 

such as: 
●​ Player names 
●​ Tee times 
●​ Start holes 
●​ Affiliations, etc. 

●​ You can customize: 
●​ Font family 
●​ Font size 
●​ Color 
●​ Style (e.g., bold, etc.) 

This is how Page Composer generates personalized labels, signs, and documents without you 
manually typing data. 

Adding Logos and Photos 
●​ You can add: 

●​ Event logos 
●​ Photos from albums 
●​ Newly uploaded photos 

●​ Once placed on the design area: 
●​ Drag to reposition. 
●​ Resize as needed. 

●​ The numbered placeholders (e.g., #1, #2, #5) correspond to text field slots: 
●​ Example: #5 might be the event name, #1 and #2 might be player names. 

This allows you to brand your reports and create visually polished documents. 

Other Design Tools 
Page Composer includes several additional layout tools: 

1.​ Golf Hub QR Code 
●​ Insert a scannable QR code that links directly to the event/league Golf Hub page. 
●​ Useful for cart signs, posters, or registration sheets that drive players to live 

scoring, schedule, and event info. 
2.​ Add Rectangle 

●​ Draw rectangles of any size. 
●​ Control: 

●​ Fill color 
●​ Border width 
●​ etc. 

●​ Resize by dragging corners. 
●​ Great for callout boxes, headers, backgrounds, or table-like structures. 



3.​ Add Line 
●​ Add lines with: 

●​ Adjustable length 
●​ Width 
●​ Color 
●​ Angle 

●​ Useful for separators, signature lines, or visual structure. 
4.​ Duplicate 

●​ Quickly duplicate any: 
●​ Image 
●​ Rectangle 
●​ Line 
●​ Text box 

●​ Speeds up building symmetrical layouts or grids. 
5.​ Layering: Send to Back / Send to Front 

●​ Control z-order of content when elements overlap. 
●​ Example: Put a background image behind everything else or place text on top of 

a colored rectangle. 
6.​ Watermarking 

●​ Create watermarks using images: 
●​ Add an image. 
●​ Move and enlarge it to fill the desired area. 
●​ Adjust photo transparency. 
●​ Send to back, so it sits behind all other content. 

●​ Typical use: semi-transparent club logo behind scorecards or event documents. 
 

Preview and Finalizing 
●​ You can refresh the preview as you design to see how the report will look with real data 

and layout changes. 
●​ When satisfied: 

●​ Click Save and Print to move to output. 

Sharing & Community Reports 
●​ Any Page Composer report can be published to the Community Reports if you want 

others to use your design. 
●​ To publish/unpublish: 

●​ Click Edit near the report’s status and adjust the community-sharing options. 
●​ This enables sharing best-practice layouts (cart signs, bag tags, labels, etc.) across the 

broader Golf Genius user community. 



Forms: Defining Paper Size and Layout Grids 
A Form controls the underlying page structure: 

●​ To create a new one:​
Rounds > Report Center > New Document > New Page > Manage Forms > Add New 
Form 

When creating a form, you can: 
1.​ Set paper size 

●​ Example: 8.5 x 11 inches. 
2.​ Configure margins 

●​ Outside margins (page edges). 
●​ Inside margins (gaps between columns/rows). 

3.​ Set number of columns and rows 
●​ Example for custom cart signs: 

●​ 1 column, 2 rows → 2 cart signs per page. 
●​ Example for Avery 5160 labels: 

●​ 3 columns, 10 rows. 
●​ A live preview on the right updates as you change specs, helping ensure labels/signs 

line up correctly. 
Once you save a form: 

●​ It becomes available for all events and leagues in your account. 
●​ Any Page Composer report can reference that form, making it easy to standardize 

layouts. 

Configuring Reports for Specific Rounds/Tournaments 
If you’re using or copying an existing report (rather than building from scratch), you may need to 
configure it for a particular round: 

●​ From Rounds > Report Center: 
●​ Find the report. 
●​ Hover and click Configure. 

The configuration popup: 
●​ Shows: 

●​ Which dynamic fields are in use. 
●​ How they are currently configured. 

●​ You specify: 
●​ Which round and/or tournament each dynamic field should draw from. 

Examples: 
●​ Tee times: 

●​ Vary by round and course. 
●​ You must pick the correct round so fields like “Tee Time” pull the right data. 



●​ Scores: 
●​ Change by round and tournament. 
●​ If you want a report to display “Round 1 score next to each player’s name,” you 

must: 
●​ Select the correct round (Round 1). 
●​ Select the correct tournament. 

●​ If a report was designed in Round 1 but should also be reused in Round 2: 
●​ Configure for Round 1. 
●​ Then configure again for Round 2 so the dynamic fields update appropriately. 

This configuration step is what makes a single design reusable across multiple rounds and 
events. 

Printing and Filtering Options 
After configuration and when you go to print, Page Composer offers several output controls: 

1.​ Print For 
●​ Depending on how the report was set up: 

●​ Print for every player in: 
●​ The round’s tee sheet 
●​ The round roster 
●​ All players in the league/event 

●​ Aligns with the earlier “Print for every” setting but allows contextual choice at print 
time. 

2.​ Sort Players 
●​ If printing per player, set the sorting order: 

●​ For example, by last name, tee time, flight, etc. 
3.​ Organize Reports by Course 

●​ If a round uses multiple courses, you can separate output by course. 
4.​ Filtering by Custom Fields 

●​ Restrict printing to a subset of players based on custom field values, such as: 
●​ Riders Only for cart signs. 
●​ Guests Only for bag labels. 

●​ This is powerful for operational tasks where only certain players need certain 
materials. 

5.​ Adjust Page Margins 
●​ Fine-tune vertical margins to align with physical paper or labels (especially 

important for label stock like Avery 5160). 
●​ Helps fix minor misalignments without editing the underlying form. 

6.​ Print Process & Recommendations 
●​ On the print options page: 

●​ Select “Actual size”, not “Fit” or “Fit to page.”​
Otherwise, label alignment will be off. 

●​ The article recommends: 



●​ Create a PDF and print from the PDF, rather than printing directly from the 
browser, to improve alignment and consistency. 

Practical Capabilities Summary 
Putting it all together, the Golf Genius Page Composer enables you to: 

●​ Design rich, branded, and data-driven print documents: 
●​ Cart signs 
●​ Bag labels 
●​ Name badges 
●​ Score summaries 
●​ Custom signage 
●​ And more 

●​ Use: 
●​ Dynamic golf-specific data (players, scores, rounds, flights, tournaments). 
●​ Custom fields for advanced segmentation and personalization. 

●​ Precisely control: 
●​ Page structure via forms (paper size, rows, columns, margins). 
●​ Visual design (text formatting, images/logos, rectangles, lines, watermarks). 
●​ Layering and layout (front/back ordering, duplication, positioning). 

●​ Integrate: 
●​ Golf Hub QR codes to connect printed content to digital experiences. 

●​ Reuse and share: 
●​ Configure per round/tournament to reuse a single design. 
●​ Publish to or draw from Community Reports. 
●​ Mark “template” reports for organization-wide standardization and protection. 
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